Вы зашли как: Гость
1
Не в сети
Сообщений: 41
Благодарностей: 2
Предупреждений:
Из: Ukraine Неважно
Род занятий: Дизайнер

При работе заметил что в некоторых приложениях семерка непонимает некоторые слова и вместо них вот такие символы:
в квипе



и в Download Master


что это? Плохой русик или баг винды?


Сообщение было отредактировано netRunner (12.01.2009 10:28 GMT+3 часа(ов), назад)

#150857   | 04.01.2009 23:20 GMT+3 часа(ов)
Не в сети
Сообщений: 1306
Благодарностей: 106
Предупреждений:
Из: Russia Krasnodar
Род занятий:

ArtDevison, воспользуйтесь поиском по форуму! Сколько раз уже обсуждалось!?

"Линуксоиды идут в баню. Сайт TheVista.Ru не для вас"
deeper2k

#150859   | 04.01.2009 23:25 GMT+3 часа(ов)
Не в сети
Сообщений: 41
Благодарностей: 2
Предупреждений:
Из: Ukraine Неважно
Род занятий: Дизайнер

Сории...... Невидел тему можно удалить

#150860   | 04.01.2009 23:32 GMT+3 часа(ов)
Не в сети
Сообщений: 1
Благодарностей: 0
Предупреждений:
Из: Russia
Род занятий:

Зайди в Control Panel>Regional and Language Options(Formats, Location и обязательно Administrative>Change system locate) и измени все языковые настройки на RUSSIAN . Перезагрузи компьютер.

#150863   | 05.01.2009 01:41 GMT+3 часа(ов)
Не в сети
Сообщений: 152
Благодарностей: 2
Предупреждений:
Из: Russia Киселёвск
Род занятий:

Для тех, кому не помогает:

Цитата:
Dimi :
По поводу отображения русского шрифта

Пробуйте.....

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Nls\CodePage]
"1252"="c_1251.nls"

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\FontSubstitutes]
"Arial,0"="Arial,204"
"Comic Sans MS,0"="Comic Sans MS,204"
"Courier,0"="Courier New,204"
"Microsoft Sans Serif,0"="Microsoft Sans Serif,204"
"Tahoma,0"="Tahoma,204"
"Times New Roman,0"="Times New Roman,204"
"Verdana,0"="Verdana,204"


Данный файл реестра также работает и в английской раскладке, в которой работает родной гаджет погоды и правильно отображается русский шрифт


Но у меня и это не исправило ситуацию!!! У меня программа специализированная (рабочая), там все буквы отображаются знаками вопроса. В Висте все было нормально. Что еще можно сделать???


Сообщение было отредактировано Kudesnick (06.01.2009 04:58 GMT+3 часа(ов), назад)

#150975   | 06.01.2009 04:41 GMT+3 часа(ов)
Не в сети
Сообщений: 152
Благодарностей: 2
Предупреждений:
Из: Russia Киселёвск
Род занятий:

Может кто еще что-нить подскажет?

#151171   | 07.01.2009 17:22 GMT+3 часа(ов)
Не в сети
Сообщений: 47
Благодарностей: 5
Предупреждений:
Из: Russia 12
Род занятий: M G D

Цитата:
Kudesnick :
Может кто еще что-нить подскажет?


У меня не было такой проблемы до установки сборки 7000. А тут именно то что ты описываешь.

Простые методы на форуме не помогали, либо вновь сбрасывал слова Download Master, либо снова вопросы вместо букв в квипе.

Вобщем дополнительно к вышеприведенному регу я воспользовался советом пободной проблемы для висты, а именно:

в папке C:\WINDOWS\system32 есть файл С_1252 и С_1251, так вот, скопируй куда-нибудь С_1251 - переименуй С_1251 в С_1252, а оригинальный С_1252 удали или переименуй например c_1252_old (дав права на него) и вставь назад в C:\WINDOWS\system32 новый перименованный С_1251 в С_1252 и перезагрузись.

+ запусти рег который запостили выше

+ в QIP я убрал галочку в настройках с: Messaging Window-> "Disable RTF message support"

Это должно помочь. После этих манипуляций проверяешь русский язык с кем нибудь из контакт листа и смело переименовываешь имена в листе на русский вновь и больше ничего не должно меняться.

А в Download Master мне пришлось даже задать папки сохранения на английском языке до этого...

ps: конечно же ничего лишнего "english" не должно быть в региональных настройках, english у меня только в Display Language..

Поблагодарили: Kudesnick

love interface (c) vienna

#151179   | 07.01.2009 17:38 GMT+3 часа(ов)
Не в сети
Сообщений: 10
Благодарностей: 1
Предупреждений:
Из:
Род занятий:

Но на самой форме всё равно будут кракозябли? Я так понимаю? Проблема всё равно есть.

Я сам пользуюсь QIP Infium расскажу немного о своей борьбе. Там ситуация несколько другая, но тоже есть проблема.

Во первых все хинты в проге изначально писались в виде вопросительных знаков. Так-же само окно выбора статусов, и частично контекстные меню.

Я нашел такой способ борьбы, я обновил шрифты в системе теми, которые были у меня в XP. Проблема ушла. Хотя до этого я уже вносил изменения в реестре, толку с этого не было. Манипуляции из этой ветки так-же результата не дали. Хотя файлы с кодировками мне подменить не удалось, типа у меня нет прав для этого. Хотя я под активированной записью администратора сижу.

Но вот сегодня я увидел что у меня опять появились вопросительные знаки. И что странно, к компу в течении какого-то времени никто не подходил, в это время выключился монитор и возможно винты, так как простой был больше полу часа явно.

#151415   | 09.01.2009 13:23 GMT+3 часа(ов)
Не в сети
Сообщений: 14
Благодарностей: 0
Предупреждений:
Из:
Род занятий:

Я сразу при установки сборки 7000 ставил все на русский(локацию, клаву и тд). Но после установки в квипе и некоторых других программах были проблемы с русским. Попробовал сменить всё в региональных настройках на английский, перезагрузился, и вернул на русский, еще раз перезагрузился, и теперь проблем с русским нет.

#151470   | 09.01.2009 17:10 GMT+3 часа(ов)
Не в сети
Сообщений: 177
Благодарностей: 0
Предупреждений:
Из: Russia
Род занятий:

Сделайте исправления в регистре:

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Nls\CodePage]
"1250"="c_1251.nls"
"1251"="c_1251.nls"
"1252"="c_1251.nls"
"1253"="c_1251.nls"
"1254"="c_1251.nls"
"1255"="c_1251.nls"

#151517   | 09.01.2009 20:19 GMT+3 часа(ов)
Не в сети
Сообщений: 10
Благодарностей: 1
Предупреждений:
Из:
Род занятий:

oden7, ты здесь всех за кого держишь? Уже не раз писали, что не помогает это. Вот прилагаю reg файл, который запускали:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Nls\CodePage]
"1250"="c_1251.nls"
"1251"="c_1251.nls"
"1252"="c_1251.nls"
"1253"="c_1251.nls"
"1254"="c_1251.nls"
"1255"="c_1251.nls"

ЭТА ТЕМА НЕ РАБОТАЕТ!!!

Изменял реестр, перегружал машину. Толку нет.

#151935   | 10.01.2009 09:10 GMT+3 часа(ов)
Не в сети
Сообщений: 566
Благодарностей: 5
Предупреждений:
Из: ---
Род занятий:

А всего-то нужно было при установке выбрать что мы в России живём.

#152232   | 11.01.2009 00:15 GMT+3 часа(ов)
Не в сети
Сообщений: 1306
Благодарностей: 106
Предупреждений:
Из: Russia Krasnodar
Род занятий:

Freto, у кого-то даже на это мозгов не хватает.

"Линуксоиды идут в баню. Сайт TheVista.Ru не для вас"
deeper2k

#152233   | 11.01.2009 00:25 GMT+3 часа(ов)
Не в сети
Сообщений: 47
Благодарностей: 5
Предупреждений:
Из: Russia 12
Род занятий: M G D

Цитата:
Freto :
А всего-то нужно было при установке выбрать что мы в России живём.


Как нистранно люди указывают русский везде где можно указать при установке и бывает такая балалайка. Я сам в первые столкнулся так серьезно с этим после установки именно билда 7000...

Цитата:
Dj Rus :
Freto, у кого-то даже на это мозгов не хватает.


Бывают же люди...

love interface (c) vienna

#152242   | 11.01.2009 01:20 GMT+3 часа(ов)
Не в сети
Сообщений: 566
Благодарностей: 5
Предупреждений:
Из: ---
Род занятий:

-creo-,
В самом-самом начале, когда Вы только вставили диск и загрузились, вот именно там нужно указать русский. Тогда всё-всё система сделает для того, чтобы вопросиков и значков у Вас не появилось.
Лично я с таким никогда не встречался.

#152243   | 11.01.2009 01:25 GMT+3 часа(ов)
Не в сети
Сообщений: 177
Благодарностей: 0
Предупреждений:
Из: Russia
Род занятий:

Цитата:
ERadchenko :
oden7, ты здесь всех за кого держишь? Уже не раз писали, что не помогает это. Вот прилагаю reg файл, который запускали:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Nls\CodePage]
"1250"="c_1251.nls"
"1251"="c_1251.nls"
"1252"="c_1251.nls"
"1253"="c_1251.nls"
"1254"="c_1251.nls"
"1255"="c_1251.nls"

ЭТА ТЕМА НЕ РАБОТАЕТ!!!
to ERadchenko ! Ну если мы уже на "ты", то тебя я лично вообще ни за кого не держу, а остальным советую попробывать,у меня работает на 100%. Таke it easy! Cool хацкер! Т.е. будь попроще и народ к тебе потяниться! Пардон за offtop,но не люблю когда хамят!



Сообщение было отредактировано oden7 (11.01.2009 02:20 GMT+3 часа(ов), назад)

#152263   | 11.01.2009 02:11 GMT+3 часа(ов)
Не в сети
Сообщений: 10
Благодарностей: 1
Предупреждений:
Из:
Род занятий:

А я не люблю когда приходят и в сто первый раз говорят, что мол всё вы дураки и не лечитесь. Поставьте русский язык или измените реестре. Хотя уже писалось что это не помогает, и при установке лично МНОЮ был выставлен РУССКИЙ ЯЗЫК.

Format : Russia
Location : Russia
Current language for non-Unicode programs: Russia

Что мне ещё выставить? И эти настройки у меня были сразу после установки Win7. В реестре у меня
"1250"="c_1251.nls"
"1251"="c_1251.nls"
"1252"="c_1251.nls"
"1253"="c_1251.nls"
"1254"="c_1251.nls"
"1255"="c_1251.nls"

Особо одаренные товарищи, которые утверждают, что у кого то не хватает мозгов, памяти и т.д. Расскажите мне тупому и убогому что же ещё сделать.

#152303   | 11.01.2009 08:17 GMT+3 часа(ов)
Не в сети
Сообщений: 27
Благодарностей: 0
Предупреждений:
Из:
Род занятий:

я решил эту проблему тем что на вкладке форматы аплета панели управления(региональные и языковые параметры) сначала выставил английский формат, применя его , а потом выставил русский , нажал окей. Теперь во всех программах русские символы отображаются нормально.

#152421   | 11.01.2009 21:19 GMT+3 часа(ов)
Не в сети
Сообщений: 247
Благодарностей: 3
Предупреждений:
Из: Russia Москвва
Род занятий: Фотограф

имхо, ставьте ICQ нормальную.. и нет проблем)))

#152425   | 11.01.2009 22:09 GMT+3 часа(ов)
Не в сети
Сообщений: 89
Благодарностей: 18
Предупреждений:
Из: Ukraine Харьков
Род занятий:

Цитата:
ERadchenko :
А я не люблю когда приходят и в сто первый раз говорят, что мол всё вы дураки и не лечитесь. Поставьте русский язык или измените реестре. Хотя уже писалось что это не помогает, и при установке лично МНОЮ был выставлен РУССКИЙ ЯЗЫК.

Format : Russia
Location : Russia
Current language for non-Unicode programs: Russia

Что мне ещё выставить? И эти настройки у меня были сразу после установки Win7. В реестре у меня
"1250"="c_1251.nls"
"1251"="c_1251.nls"
"1252"="c_1251.nls"
"1253"="c_1251.nls"
"1254"="c_1251.nls"
"1255"="c_1251.nls"

Особо одаренные товарищи, которые утверждают, что у кого то не хватает мозгов, памяти и т.д. Расскажите мне тупому и убогому что же ещё сделать.


Попробуй удалить программу,которая неправильно отображает киррилицу, и установить её снова.
И верни реестр так как был изначально, кроме ключа 1252.
Пробуй...

AGP жив, AGP не сдается...

#152427   | 11.01.2009 22:13 GMT+3 часа(ов)
Не в сети
Сообщений: 461
Благодарностей: 28
Предупреждений:
Из: Russia
Род занятий:

Для вас умных - у меня тоже проблемма хоть я и выберал русский при начальной установке))

#152457   | 12.01.2009 03:53 GMT+3 часа(ов)
Не в сети
Сообщений: 70
Благодарностей: 0
Предупреждений:
Из:
Род занятий:

я тоже выбрал русский при установке - проблема такая же

#152623   | 13.01.2009 14:28 GMT+3 часа(ов)
Не в сети
Сообщений: 27
Благодарностей: 0
Предупреждений:
Из:
Род занятий:

я тоже выбирал русский при установке!! но решил проблему именно так. видно при установке русский выставился не полностью, и частично заменился английским

#152632   | 13.01.2009 15:44 GMT+3 часа(ов)
Все права принадлежат © MSInsider.ru и TheVista.ru, 2014
Сайт является источником уникальной информации о семействе операционных систем Windows и других продуктах Microsoft. Перепечатка материалов возможна только с разрешения редакции.
Работает на WMS 1.1 (Страница создана за 0.561 секунд (Общее время SQL: 0.364 секунд - SQL запросов: 90 - Среднее время SQL: 0.00404 секунд))